By black fingernail
#86019
She broke down!
1998 500 bullet de-luxe.
Bimbling along nicely, on my way home, as usual, then she missed a beat or two, but carried on ok. Slowed down for traffic, lost all power and stopped. she started again, then faded and stopped altogether, trying to re-start, no dice, the ammeter was all erratic, so electrical fault it is then!
After a bit of fiddling about and testing, a bullet connector joint on the low tension wire between the points and the coil was broken inside the insulation, cut the wire back and twisted it together, it got me home.
A new wire made up to go directly between points and coil without any connectors, made up, with a shrink sleeve full length fitted to hopefully ensure reliability, fitted.
Now all good.
The wiring is getting a bit stiff and brittle after 20 years, plus when I got her the wiring inside the headlight unit was just a frightful bundle of spaghetti, I think I might change the loom this winter, I really do not like being at the side of the road scratching my head, when I could be eating my dinner.
By Beezabryan
#86022
Had a few transient electrical niggles over the years & each time I decided that rewiring would be good. But then when after a minor adjustment the old beast carries on faultlessly I decide it aint't too broken therefore I've never mended it.
I know I really should and maybe this winter I might possibly buy some lengths of cable plus a fistful of connectors.
If and when I do the stuff will bought from a reputable source, not cheap shyte off fleabay or the like.

Shop for accessories at Hitchcocks Motorcycles