Page 1 of 1

Electra X Electrics broke and fixed again

Posted: Fri Oct 18, 2019 7:21 pm
by Cov Lad
Despite changing to blade fuses my bike decided to loose power once more. After hunting behind the air filter, removing tank once more I finally found that the junction up to the ammeter was not clipped together properly. I also discovered another junction disconnected under seat area. However on rejoining I found a loss of spark. I suspect someone has altered the wiring or could it be for something else. I now need to cram all of the disturbed wires back under the covers. Can anyone advise what the multi links do and where they should sit on the bike? I really hope that I can now put some miles on this barsteward of a bike. I will add some pictures as a reply on my phone.

Re: Electra X Electrics broke and fixed again

Posted: Fri Oct 18, 2019 7:28 pm
by Cov Lad
31B67071-4370-4F53-B209-9BDC734D8526.jpeg
FB717B45-3409-42D2-A9F2-214F450D86CC.jpeg
Image

Re: Electra X Electrics broke and fixed again

Posted: Fri Oct 18, 2019 10:17 pm
by Adrian
Did I mention it's probably best to get hold a copy of the Electra-X workshop manual? It has both partial and complete wiring diagrams, so that you can compare what is actually on the bike with what is SUPPOSED to be there.

http://accessories.hitchcocksmotorcycle ... uilt/10701

My own Electra (my second) has had its wiring hacked by a P.O., and with that and the usual problems with Indian wiring looms of a certain age being prone to deteriorate, as experienced on my previous Electra, I'm taking the old wiring loom off and re-wiring the bike with a nice fresh chunk of 13 x 1.5mm multi-core as the basis of the new loom, hopefully simplifying a few things on the way.

Yes, I shall be using spade fuses too.

A.

Re: Electra X Electrics broke and fixed again

Posted: Fri Nov 01, 2019 10:02 pm
by Cov Lad
The previous owner did fit handlebar heaters, this may have disturbed the electrics. I have disconnected them at the battery and will probably get rid of them at some point.

Re: Electra X Electrics broke and fixed again

Posted: Sat Nov 02, 2019 1:07 pm
by Adrian
People hack into the wiring loom for all sorts of things, mine had an immobiliser installed which was a real pain to use, I was glad to rip it all out.

A.

Re: Electra X Electrics broke and fixed again

Posted: Fri Nov 08, 2019 8:31 pm
by Simon D
Cover lad

The new unconnected wires are they green?

SD.

Re: Electra X Electrics broke and fixed again

Posted: Sat Nov 09, 2019 12:50 am
by stinkwheel
Just wow. I do not know where to start. I count three extra wires on the battery positive alone. Multiple inline fuses.

Image

Re: Electra X Electrics broke and fixed again

Posted: Sat Nov 09, 2019 1:12 pm
by Adrian
There are normally 2 fuses on an Electra-X, one for the battery and another for the TCI unit.

Most of the old wiring off my Electra has been removed, and I have started the re-wire. I'm using different switchgear intended for a K/S Bullet, so there are some fun and games wiring the switch for all DC lighting, as well as sorting out a separate starter button. Will probably spend this rather wet afternoon squinting over the wiring diagrams in the manual and drawing up my own, allocating each of the 13 colours in the multicore flex as logically as an old fool possibly can.

The challenge (ho ho!) is to keep it simple, neat and effective. Definitely no chocolate block connectors, just Japanese-style 3.9mm bullets and 2.8mm multi connectors where possible, with the odd ring terminal and 6.3mm blade/spade as required, plus some of the specials for the TCI and coil from our Hosts (on order).

A.